CVE-2016-10142 json
An issue was discovered in the IPv6 protocol specification, related to ICMP Packet Too Big (PTB) messages.
published 2017-01-14 9 y ago modified 2026-06-17 4 mo ago also EUVD-2016-1331
- cvss
- 8.6
- version 3.0, NVD
- cisa kev
- Not listed
- not in CISA's catalog
- epss
- 2.8%
- EPSS 2.8% chance of exploitation in 30 days, percentile 86%
- public exploits
- 0
- none known
Summary
An issue was discovered in the IPv6 protocol specification, related to ICMP Packet Too Big (PTB) messages. (The scope of this CVE is all affected IPv6 implementations from all vendors.) The security implications of IP fragmentation have been discussed at length in [RFC6274] and [RFC7739]. An attacker can leverage the generation of IPv6 atomic fragments to trigger the use of fragmentation in an arbitrary IPv6 flow (in scenarios in which actual fragmentation of packets is not needed) and can subsequently perform any type of fragmentation-based attack against legacy IPv6 nodes that do not implement [RFC6946]. That is, employing fragmentation where not actually needed allows for fragmentation-based attack vectors to be employed, unnecessarily. We note that, unfortunately, even nodes that already implement [RFC6946] can be subject to DoS attacks as a result of the generation of IPv6 atomic fragments. Let us assume that Host A is communicating with Host B and that, as a result of the widespread dropping of IPv6 packets that contain extension headers (including fragmentation) [RFC7872], some intermediate node filters fragments between Host B and Host A. If an attacker sends a forged ICMPv6 PTB error message to Host B, reporting an MTU smaller than 1280, this will trigger the generation of IPv6 atomic fragments from that moment on (as required by [RFC2460]). When Host B starts sending IPv6 atomic fragments (in response to the received ICMPv6 PTB error message), these packets will be dropped, since we previously noted that IPv6 packets with extension headers were being dropped between Host B and Host A. Thus, this situation will result in a DoS scenario. Another possible scenario is that in which two BGP peers are employing IPv6 transport and they implement Access Control Lists (ACLs) to drop IPv6 fragments (to avoid control-plane attacks). If the aforementioned BGP peers drop IPv6 fragments but still honor received ICMPv6 PTB error messages, an attacker could easily attack the corresponding peering session by simply sending an ICMPv6 PTB message with a reported MTU smaller than 1280 bytes. Once the attack packet has been sent, the aforementioned routers will themselves be the ones dropping their own traffic.
Patch / fix
- linux Ubuntu 14.04 LTS 3.13.0-51.84
ubuntu advisories UBUNTU-CVE-2016-10142
Ubuntu security data © Canonical Ltd., from https://github.com/canonical/ubuntu-security-notices via OSV; changed: normalised to fixed package versions per release. CC BY-SA 4.0
- kernel RHEL 6 2.6.32-696.el6
- perf RHEL 6 2.6.32-696.el6
- python-perf RHEL 6 2.6.32-696.el6
- kernel-kdump RHEL 6 2.6.32-696.el6
- kernel-firmware RHEL 6 2.6.32-696.el6
- kernel-bootwrapper RHEL 6 2.6.32-696.el6
- kernel-abi-whitelists RHEL 6 2.6.32-696.el6
- kernel-debuginfo-common-i686 RHEL 6 2.6.32-696.el6
red hat advisories RHSA-2017:0817
Vendor advisories
What the vendors themselves say about their products: affected, fixed or not affected, and what to do.
red hat product security vex CVE-2016-10142 updated cvss 5.8
kernel - IPV6 fragmentation flaw
-
Red Hat Enterprise Linux Desktop (v. 6) perf 2.6.32-696.el6, kernel 2.6.32-696.el6, kernel-firmware 2.6.32-696.el6, kernel-abi-whitelists 2.6.32-696.el6, kernel-debuginfo-common-i686 2.6.32-696.el6, kernel-debuginfo-common-x86_64 2.6.32-696.el6 Red Hat Enterprise Linux Desktop Optional (v. 6) python-perf 2.6.32-696.el6, kernel-debuginfo-common-i686 2.6.32-696.el6, kernel-debuginfo-common-x86_64 2.6.32-696.el6 Red Hat Enterprise Linux HPC Node (v. 6) perf 2.6.32-696.el6, kernel 2.6.32-696.el6, kernel-firmware 2.6.32-696.el6, kernel-abi-whitelists 2.6.32-696.el6, kernel-debuginfo-common-i686 2.6.32-696.el6, kernel-debuginfo-common-x86_64 2.6.32-696.el6 Red Hat Enterprise Linux HPC Node Optional (v. 6) python-perf 2.6.32-696.el6, kernel-debuginfo-common-x86_64 2.6.32-696.el6 Red Hat Enterprise Linux Server (v. 6) perf 2.6.32-696.el6, kernel 2.6.32-696.el6, kernel-kdump 2.6.32-696.el6, kernel-firmware 2.6.32-696.el6, kernel-bootwrapper 2.6.32-696.el6, kernel-abi-whitelists 2.6.32-696.el6, +4 more Red Hat Enterprise Linux Server Optional (v. 6) python-perf 2.6.32-696.el6, kernel-debuginfo-common-i686 2.6.32-696.el6, kernel-debuginfo-common-ppc64 2.6.32-696.el6, kernel-debuginfo-common-s390x 2.6.32-696.el6, kernel-debuginfo-common-x86_64 2.6.32-696.el6fixed: vendor fix RHSA-2017:0817
+2 more productsfewer
Red Hat Enterprise Linux Workstation (v. 6) perf 2.6.32-696.el6, kernel 2.6.32-696.el6, kernel-firmware 2.6.32-696.el6, kernel-abi-whitelists 2.6.32-696.el6, kernel-debuginfo-common-i686 2.6.32-696.el6, kernel-debuginfo-common-x86_64 2.6.32-696.el6 Red Hat Enterprise Linux Workstation Optional (v. 6) python-perf 2.6.32-696.el6, kernel-debuginfo-common-i686 2.6.32-696.el6, kernel-debuginfo-common-x86_64 2.6.32-696.el6 -
Red Hat Enterprise Linux 4 kernel Red Hat Enterprise Linux 5 kernel Red Hat Enterprise Linux 7 perf, kernel, bpftool, kernel-rt, python-perf, kernel-kdump, +8 more Red Hat Enterprise MRG 2 kernel-rt, mrg-rt-release, kernel-rt-trace, kernel-rt-vanilla, kernel-rt-firmwarenot affected: vulnerable code not present
Red Hat CSAF VEX © Red Hat, Inc., from https://security.access.redhat.com/data/csaf/v2/vex/; changed: reduced to product statuses and remediations. CC BY 4.0 · csaf
Exploit prediction
2.80% chance of exploitation in the next 30 days, higher than 86% of all scored CVEs (FIRST EPSS, 2026-11-09).
CVSS scores
| assigned by | version | score | vector |
|---|---|---|---|
| NVD | 3.0 | 8.6 | CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H |
| NVD | 2.0 | 5.0 | AV:N/AC:L/Au:N/C:N/I:N/A:P |
Classification
- Weakness
-
- CWE-17 DEPRECATED: Code
References
-
rhn.redhat.com
/errata/RHSA-2017-0817.html
vendor-advisory
-
tools.ietf.org
/html/draft-ietf-6man-deprecate-atomfrag-generation-08
third-party-advisory
-
tools.ietf.org
/html/rfc8021
third-party-advisory
-
securityfocus.com
/bid/95797
vdb-entry
- kb.pulsesecure.net /articles/Pulse_Security_Advisories/SA43730
-
securitytracker.com
/id/1038256
vdb-entry
- support.f5.com /csp/article/K57211290?utm_source=f5support&%3Butm_medium=RSS
Sources
- CVE List CVE-2016-10142
- NVD CVE-2016-10142
Fencer Intel keeps one entry per vulnerability: the CVE id wins, then GHSA, and records that alias each other are merged, except that two CVEs always keep separate entries. The same data is available as JSON.